Dr KNX: Updating ETS4 Despite a Proxy-Related Issue

Dr KNXBy Dr KNX.

Dear Dr KNX, I cannot update ETS4 because of a proxy-related issue on my PC. Can you help?

Dear Dr KNX, I cannot update ETS4 because of a proxy-related issue on my PC. Can you help?

Dear KNXer,

KNX Association decided to allow ETS updates only for valid licenses, in order to avoid the illegal use of ETS. Depending on its configuration settings, ETS checks for available updates either automatically or manually. Before installing such an update, ETS checks whether any installed licenses are valid. If there is any invalid license present, ETS will refuse to install the update.

Example of ETS set up for checking for updates automatically.

Example of ETS set up for checking for updates automatically.

HOWEVER: it can indeed be the case that ETS simply cannot download the actual ‘ETS Update’ setup file, despite a perfectly valid license installed. The reason for this is that the security policy installed on your (company’s) Internet gateway requires specific proxy settings, which ETS unfortunately does not support. You can get more information from here: http://support.microsoft.com/kb/135982/en-us

Solution

In such cases, the only solution is to request the KNX Offline License Validation tool. You need to request this tool via a support ticket in your KNX Online Shop account (under ‘My Support’) and obviously the account used for this request must be linked to the license(s) that cannot be updated.

I hope that helps, but if you have any questions about this, or any other technical issue, please use the ‘Leave a reply’ option below this article, or send me an email at info@knxtoday.com, and I will do my best to answer you.

Yours truly
Dr KNX



Leave a reply (comments are moderated)